Gamemaker studio android game erstellen?

      Gamemaker studio android game erstellen?

      Hallo
      immer wenn ich mit gamemaker studio versuch mein spiel für android zu erstellen kommt nur eine .droid datei mit der kann ich ja nix anfangen ich brauche doch eine .apk
      wie funktioniert das ganze ich verstehe nix wie ich meine .apk datei bekommen soll
      MFG
      Hoffe auf hilfe
      1. Du Downloads und installierst Android SDK.
      2. Du Downloads und Installierst Java SE Development Kit (JDK).
      3. Musst Du denn Android SDK Manager starten und diese Pakete Runterladen, Android 2.1 (API 7), Android 2.2 (API 8), Android 3.0 (API 11).
      4. Aktivierst du USB Debugging unter Einstellungen > Apps(Anwendungen) > Entwicklung am Android Gerät.
      5. Verbindest du das Android Gerät mit dem Computer (meistens wird es als Wechseldatenträger erkannt).
      6. Stelle denn Game maker so ein, wie Du es auf dem Bild siehst.
      7. Starte denn Game maker und schau im Geräte Manager nach, ob dein Android Gerät erkannt wurde.
      8. Falls das Gerät nicht erkannt wurde, musst du einen USB-Treiber installieren gibt es beim Hersteller.
      9. Führe ein Projekt aus (es sollte nun funktionieren).
      Bilder
      • Android_Preferences.png

        13,39 kB, 617×426, 546 mal angesehen
      Meine Webseite: jesoftmedia.de
      Studio Professional v1.4.1772

      Max77771 schrieb:

      Du Downloads und Installierst Java SE Development Kit (JDK).


      Version 9 hab bei mir Probleme gemacht musste Version 8 installieren

      Max77771 schrieb:

      Aktivierst du USB Debugging unter Einstellungen > Apps(Anwendungen) > Entwicklung am Android Gerät.


      Hab erst mal wie Verückt gesucht, weis nicht ob ich es Witzig oder Scheisse finden soll XD
      Naja vielleicht brauchts noch jemand, hier die Lösung:
      giga.de/extra/android-spezials…aktivieren-einstellungen/
      Vielleicht kann mir jemand von den Pros hier helfen, bekomme bei einem Neuen Projekt keinen Fehler aber bei einem älteren diesen hier (Bild)
      Also denke ich muss Irgend ne Einstellung sein. Keine Ahnung was er mit AdvertisingBase.java will???


      Edit: Manuelles vergleichen der Config brachte nichts, sah alles gleich aus.
      Aber nachdem ich den Config Ordner gelöscht hatte und aus einem neuen Projekt Kopiert hatte funktionierte es -.- :| Bin ich froh das Studio 1 nicht mehr weiterentwickelt wird und ich erst mal meine Ruhe hab.
      Bilder
      • fehler.jpg

        48,99 kB, 502×229, 15 mal angesehen

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Balls of Steel“ ()

      Neu

      Schau am besten in dem folgenden link, diese SDK und NDK werden vom yoyogames empfohlen: help.yoyogames.com/hc/en-us/ar…48-GM-S-1-4-Required-SDKshelp.yoyogames.com/hc/en-us/ar…48-GM-S-1-4-Required-SDKs
      Unter "Global Game Settings" im Menü android stellst du dann "build tools" und "support lib" ein (stell die Anfangsnummern nicht über die Nummer der max-SDK sonst bekommst du Fehlermeldungen ) bei max SDK würde ich nicht über 23 installieren da GM da noch viele Bugs hat. Als min kannst du 15 einstellen damit funktionieren über 90% alle Smartphones auf der Welt.(passe auf wenn du Extensions vom Marktplatz holst musst du darauf achten welche min-max SDK dort verwendet wurde). Damit alles funktioniert musst du die richtigen Dinge wie build tools und API im SDK Manager runter laden, dort kannst du auch sehen welche Versions-Nummer du z.b. für build tools im GM nach dem installieren verwenden kannst. die support lib sind etwas besser versteckt unter Windows findest du sie unter "deinlaufwerkbuchstabe:\AndroidDT\adt-bundle-windows-x86_64-20140702\sdk\extras\android\m2repository\com\android\support\appcompat-v7" , dort sind die Ordner bereits nach den Versionsnummern die du verwenden kannst benannt. Java JDK 9 ist noch zu neu für den aktuellen GM . Achtung bei den ganzen Updates mit den SDKs und NDKs oder build tools hier gilt nicht neuer = besser sondern fast immer kommt mit einer neuen support lib etwas hinzu was eine ältere API und vor allem der GM nicht mehr unterstützen. Das heißt wenn du für ein Smartphone programmierst welches z.b. API 10 nutzt und du installierst die aller neuesten build tools +JDK usw werden viele Funktionen aus der alten API nicht mehr unterstützt und dein Programm wird eventuell nicht mehr richtig funktionieren(meist aber wird es gar nicht erst erstellt werden können weil der GM vorher rumzickt).

      Zu deinem Problem entweder Game Maker hatte nicht die Berechtigung bei dir auf den Ordner zuzugreifen oder dieser existierte nicht. Dann hilft meist bevor du die APK erstellst, ganz oben links auf "File" dann "Preferences" dort dann auf "Clear Temp Data" und Clear Asset Cache" drücken .Dann erst auf APK erstellen klicken. Game Maker legt dann neue Ordner an.
    • Benutzer online 1

      1 Besucher