Probleme mit Google Mobile Ads

    Probleme mit Google Mobile Ads

    Hallo zusammen,
    ich habe Probleme mit der Werbung die ich gegebenenfalls in meine App einbauen möchte.
    Ich habe mir einfach irgendein Anbieter genommen (dieser ist in diesem Fall Google (AdMob))
    Da es wie befürchtet nicht allzu leicht wird hab ich dieses Tutorial Link in mein Project praktisch 1 zu 1 übernommen.
    Es besteht nun das Problem das dieser Fehler beim Compilen auftaucht:
    Spoiler anzeigen
    ​FAILURE: Build failed with an exception.

    * What went wrong:
    A problem occurred configuring project ':com.TwoDGameZ.FlappyRPG'.
    > failed to find Build Tools revision 23.0.1

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

    BUILD FAILED

    Total time: 5.014 secs
    Create finished: 21:44:26

    Das wahrscheinlich größere Problem ist das dieser Fehler auch bei der von YoYoGames bereitgestellten Demo passiert.
    Ich glaube eher nicht das es an der Demo liegt sondern an Game Maker selbst.
    Meine Game Maker Version: (Professional - Das ist glaube ich nicht relevant) 1.4.1690
    Ich habe es übrigens schon im Stable und im Beta Channel versucht beides ohne Erfolg
    und auch die anderen Demos zu den anderen Werbeanbietern ausprobiert alles ohne Erfolg
    Könnt ihr die Demo als .apk compilen?

    Off-Topic:

    Spoiler anzeigen
    ​Ob ich letztendlich wirklich Werbung in das Spiel einfüge ist mir noch unklar.
    Ich persönnlich finde es nur besser eine Werbung im Homescreen zu finden.Anstatt mit einem Kauf unzufrieden oder bei einem Spiel benachteilgt zu sein.
    Obwohl ich eh nicht viel bis gar nicht Handy Spiele spiel...
    Ich würd so gern die Welt verändern, aber Gott gibt mir den Quellcode.
    Marvin ist ein böser Hund!
    Habe mit Werbung noch nichts am hut gehabt bei GM:S. Dein Fehler deutet aber (auf den ersten unerfahrenen Blick) auf nen Falsche Einstellung im Android SDK hin.

    Hast du den schonmal andere Projekte Kompiliert zu einer apk und gespielt?

    Wenn man im Google nach deinem Fehler sucht (failed to find Build Tools .....) findet man sogar im YoYo Forum Beiträge dazu:

    gmc.yoyogames.com/index.php?showtopic=682950

    Vielleicht hilft dir das weiter.
    Danke für deine schnelle antwort.

    Bevor ich auf deine Antwort eingehe muss ich noch etwas loswerden was ich eben bemerkte.

    Da ich anscheinend die letzten Tage so viel mit diesem Fehler beschäftigt war habe ich in dieser Zeit noch nie ein Project (Ohne Werbung) in eine .apk kompiliert.
    Wie sich herausstellte weiß ich nun noch weniger was nun den Fehler verursacht.
    Da er nun auch beim normalen kompilieren (Ohne Werbung) kommt.
    Das jetzt bedeuten kann das irgendein GameMaker Update das verursacht hat oder (wie auch immer) das sich wirklich irgendwelche Einstellungen umgestellt haben.

    Nun zu deiner Antwort:
    Ja das kompilieren von apk's und spielen auf einem Handy ging vorher problemlos.
    Ich habe eben (anscheinend seit längerer zeit) in den Android SDK Manager geschaut und bemerkt das da ziemlich viel veraltet war diese was ich gerade behebe (ca. 55 %)
    Ich werde wahrscheinlich das erstmal abwarten und dann weiter schauen.


    Danke das du dir die mühe machst für mich zu googlen :D
    mein Problem war anscheinend das den Fehler immer mit der Werbung verbunden haben...
    Ich würd so gern die Welt verändern, aber Gott gibt mir den Quellcode.
    Marvin ist ein böser Hund!
    Nach dem Updaten ist zwar der Fehler verschwunden aber es ist dabei ein anderer entstanden. (Das sind diese Momenten am programmieren die ich besonders mag...)
    Die neue Fehlermeldung wollte ich ursprünglich für diesen Beitrag kopieren aber dies wird anscheinend nicht mehr wichtig sein denn ich habe nachdem ich das Internet auf die neue Fehlermeldung durchsucht habe einfach Gamemaker komplett neu installiert was alle Fehlermeldungen beseitigt hat.
    Meine Game Maker Version ist jetzt 1.4.1657
    Ich habe bewusst den Stable Channel ausgewählt damit ich gleich berichten kann ob es wirklich an einem Game Maker Update lag/liegt

    EDIT: Nach dem Update auf 1.4.1690 funktioniert es nicht mehr...
    Ich würd so gern die Welt verändern, aber Gott gibt mir den Quellcode.
    Marvin ist ein böser Hund!

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „DasFruchtzwerg“ ()

    Ok wenn ich jetzt mit der alten Version also 1.4.1657 mit der ich anscheinend apk's kompilieren kann nun ein Spiel mit der Werbung kompiliere
    kommt diese Fehlermeldung.
    Spoiler anzeigen
    BUILD FAILED
    D:\Daten\Android\android-sdk\tools\ant\build.xml:407: org.xml.sax.SAXParseException; lineNumber: 33; columnNumber: 120; Pr�fix "tools" f�r Attribut "tools:replace", das mit Elementtyp "meta-data" verkn�pft ist, ist nicht gebunden.
    at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.java:257)
    at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(DocumentBuilderImpl.java:339)
    at com.sun.org.apache.xpath.internal.jaxp.XPathImpl.evaluate(XPathImpl.java:466)
    at com.sun.org.apache.xpath.internal.jaxp.XPathImpl.evaluate(XPathImpl.java:513)
    at com.android.ant.GetTypeTask.execute(GetTypeTask.java:85)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
    at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:497)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    at org.apache.tools.ant.Task.perform(Task.java:348)
    at org.apache.tools.ant.Target.execute(Target.java:390)
    at org.apache.tools.ant.Target.performTasks(Target.java:411)
    at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
    at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
    at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
    at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
    at org.apache.tools.ant.Main.runBuild(Main.java:809)
    at org.apache.tools.ant.Main.startAnt(Main.java:217)
    at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
    at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
    --------------- linked to ------------------
    javax.xml.xpath.XPathExpressionException: org.xml.sax.SAXParseException; lineNumber: 33; columnNumber: 120; Pr�fix "tools" f�r Attribut "tools:replace", das mit Elementtyp "meta-data" verkn�pft ist, ist nicht gebunden.
    at com.sun.org.apache.xpath.internal.jaxp.XPathImpl.evaluate(XPathImpl.java:471)
    at com.sun.org.apache.xpath.internal.jaxp.XPathImpl.evaluate(XPathImpl.java:513)
    at com.android.ant.GetTypeTask.execute(GetTypeTask.java:85)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
    at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:497)
    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    at org.apache.tools.ant.Task.perform(Task.java:348)
    at org.apache.tools.ant.Target.execute(Target.java:390)
    at org.apache.tools.ant.Target.performTasks(Target.java:411)
    at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
    at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
    at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
    at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
    at org.apache.tools.ant.Main.runBuild(Main.java:809)
    at org.apache.tools.ant.Main.startAnt(Main.java:217)
    at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
    at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
    Caused by: org.xml.sax.SAXParseException; lineNumber: 33; columnNumber: 120; Pr�fix "tools" f�r Attribut "tools:replace", das mit Elementtyp "meta-data" verkn�pft ist, ist nicht gebunden.
    at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.java:257)
    at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(DocumentBuilderImpl.java:339)
    at com.sun.org.apache.xpath.internal.jaxp.XPathImpl.evaluate(XPathImpl.java:466)
    ... 18 more

    Total time: 0 seconds
    Create finished: 01:30:23

    Ich hatte vorher JDK 1.8 habe nun JDK 1.7 und es kommt die selbe Fehlermeldung.
    Trotzdem danke da ich das mit der Version 1.7 noch nicht wusste.
    Ich würd so gern die Welt verändern, aber Gott gibt mir den Quellcode.
    Marvin ist ein böser Hund!
    Aber ohne werbung geht es zu compilen?... weil ich kann mich zwar irren aber für mich sieht das so aus als wären die android preference nicht richtig eingestellt... hatte früher mit einer falschen einstellung auch so ne ähnliche fehlermeldung wenn ich mich recht erinnere
    Wir stehen zusammen und wir fallen zusammen
    Der erste Fehler sah wesentlich angenehmer aus.
    > failed to find Build Tools revision 23.0.1


    Ich glaube du hättest einfach nur im SDK Manager die revision tools für 23.0.1 installieren müssen, falls ich mich nicht irre.
    Ich habe gerade den SDK Manager nicht installiert, aber wenn ich zu Hause bin kann ich noch mal genau nachschauen (falls es noch von nutzen ist)
    Hallo

    Was stimmen muss:

    - Die Extension hast du aber in denn Gamemaker eingefügt oder?
    - Windows Uhr ist in der richtigen Zeitzone und korrekt eingestellt oder?

    ------------------------

    Hast du die Steam Version vom Gamemaker Studio?

    Eddysoulo schrieb:

    Aber ohne werbung geht es zu compilen?

    Ja das geht solange ich in der alten version von Game Maker habe.(1.4.1657) bei der neuen nicht (1.4.1690). Könnt ihr den mit dieser Version apk's kompilieren?

    Nico001 schrieb:

    Ich glaube du hättest einfach nur im SDK Manager die revision tools für 23.0.1 installieren müssen

    Dies habe ich bereits gemacht leider ohne veränderungen/verbesserungen

    Zaiq schrieb:

    - Die Extension hast du aber in denn Gamemaker eingefügt oder?
    - Windows Uhr ist in der richtigen Zeitzone und korrekt eingestellt oder?

    Ja habe ich

    Ja die Windows Uhr Stimmt.

    Nein bin erst vor kurzem zurück zur Yoyogames Version gegeangen.
    Ich würd so gern die Welt verändern, aber Gott gibt mir den Quellcode.
    Marvin ist ein böser Hund!