view, roomsize

    view, roomsize

    moin \o_

    mal ne frage...

    roomsize: 13482*1168
    view: 1366*768

    ich möchte in meinem spiel aber nur einen bestimmten bereich nutzen. über dem level und unter dem level sollen ca. 200 pixel frei bleiben für... sachen ;)
    ich stelle also in den roomsettings bei "view in room" Y:200 ein.
    baue meine spielewelt nur im unten gezeigten spielfeld.
    starte ich mein spiel, missachtet gm:s diese einstellung und beginnt den oberen rand bei Y roomsize.

    wieso?

    ums zu verdeutlichen:

    -----------------------------------------------roomsize (13482*1168)


    ---------------------------

    spielfeld (level) 1366*768

    ---------------------------


    ------------------------------------------------roomsize

    nur das spielfeld (level) soll als eigentliches spiel angezeigt werden. mit meinen jetzigen einstellungen beginnt der level aber ganz oben...



    grüße :)
    ich hatte das auch du musst dann bei port on screen oder view in room die y position ändern... ist komisch ich weiß war bei mir auch so..keine ahnung warum



    achso ich seh grad das du das mit y schon gemacht hast....wahrscheinlich hast du noch einen eigenen code für den view...ist das richtig??wenn ja macht das das problem
    hmm... ok
    liegt wohl an meinem kameraObjekt. ich nutze für das scrolling nämlich eines, da das sonst mit dem enemieSpawn nicht funktioniert.
    im stepEvent von obj_camera: view_xview[view_current] = obj_camera.x;

    ich hatte vorher eine andere roomsize, weil ich mit full hd herum experimentiert habe. da mein spiel aber mit der ursprünglichen auflösung von 1366*768 besser zu spielen ist und auch besser läuft.

    um aber ausserhalb meines spielfeldes etwas mehr platz habe, um gegner zu spawnen etc. habe ich den level umgebaut und view im leveleditor daran angepasst.

    ergänze ich nun im stepEvent vom kameraObjekt den code mit view_xview[view_current] = 200; funktioniert das ganze wieder... bis auf den screenshake ;) ich dachte, ich könnte im stepEvent statt einem festen y wert einfach obj_camera.y benutzen, aber dann stimmt der wert nicht. da gibt es wohl abweichungen...

    ich bastel mal weiter. danke, @acidrain833