If Abfrage funkt nicht

  • GM 7

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • If Abfrage funkt nicht

    Hallo!
    Ich arbeite gerade an einer kleinen Update Engine, wobei ich auf ein Problem treffe, bei dem ich nicht weiterkomme.
    Ich habe beim alarm 0 Event folgenden Code:
    Spoiler anzeigen

    GML-Quellcode

    1. if (news == 'aaa')
    2. {
    3. room_goto_next();
    4. }
    5. else
    6. {
    7. }

    Eine normale if Abfrage.


    So, beim Linklick Event habe ich folgenden Code:
    Spoiler anzeigen

    GML-Quellcode

    1. http_init();
    2. host='test.de'
    3. path='/'
    4. news=http_request(host,path+'news.php');

    das mit dem test.de ist nur ein Beispiel.
    Und ja, den Alarm Code habe ich auch mit drin.


    Nun kommt bei news.php wenn man sie aufruft ein text: aaa

    Ich kann die Variable news, nun auch per draw ausgeben, dort gibt sie mir auch aaa aus, doch bei der if Abfrage funktioniert es konmischerweise nicht.

    Ich hoffe mir kann jemand helfen.
    Danke im vorraus.

    Edit: Weiß keiner eine Antwort? Ich habe bei dem Font mal alles auf ALL gesetzt, dann gibt er: vor aaa(dem passwort) das aus: 
    dann habe ich einfach mal in die if schleife auch  eingebaut, doch es funktioniert nicht.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Heavy ()

  • Ok, danke und wie ändere ich dies nun? ^^

    EDIT:
    Ich habe es mir nun nochmal angeguckt, und sehe das dort ein Leerzeichen oder solch etwas vor ist, obwohl in der Datei gar kein Leerzeichen drin ist.
    Wieso!? Wegen den Zeichencode? Bitte um Hilfe.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Heavy ()

  • Benutzer online 2

    2 Besucher